Author Topic: 2005 R6 Idles like crap when it warms up  (Read 3576 times)

Offline Jeff2uuuh

  • Newbie
  • *
  • Posts: 10
2005 R6 Idles like crap when it warms up
« on: April 05, 2013, 09:49:56 pm »
2005 Yamaha R6
Milage: 11,600

Problem: Bike starts and runs fine when the temps. are cool. When the bike reaches temp. it starts idleing like crap. It will idle slow and lumpy till it stalls out.

Ive cleaned the TPS sensor and placed it back to the Yamahas specs. Ive also changed the plugs out. Most forums say coils or tps. Just curious if anyone has dealt with this problem?

Thanks for you help and time.


Offline IanC

  • Administrator
  • Legendary Member
  • *******
  • Posts: 2129
  • Fast from the Past
Re: 2005 R6 Idles like crap when it warms up
« Reply #1 on: April 05, 2013, 10:42:42 pm »
I believe coils are a common problem with these bikes. You can check them a couple different ways, either ohm them out and make sure they fall in factory specs or check for fire at operating temp (either the old fashioned way by pulling a plug wire and checking for spark or by checking header temps). Given the frequency of the issue with them though I'd say coils are a safe bet.
1978 Suzuki GS1000EC - Completely custom.
2012 Triumph Daytona 675R

Offline 8Ball

  • Mr. Clean
  • True Member
  • ****
  • Posts: 881
Re: 2005 R6 Idles like crap when it warms up
« Reply #2 on: April 05, 2013, 10:44:50 pm »
Do you have an after market exhaust?  Mine would not idle well when I put my Yosh full system on until I installed the Power Commander.

Coils are easy to check, but usually the problems were on the '03-04 models.  You can spray water on the pipes to see if one is running cooler.  That doesn't completely eliminate coils because they tend to fail intermittently before they completely crap out.  The best way to check them is with an ohm meter.  There is a procedure in the manual.


Since it idles fine before it warms up, I would assume it is a fueling issue and that it is too lean as it gets out of the fuel enrichment mode (automatic "choke" that is controlled by the ECU).
Quote from: jeff5150
just follow 129 on the map towards nc til it looks like a kid drawing it had a siezure
Quote from: Tomsljr
Know the difference between crack heads and Gap addicts? I have heard of people quitting crack.

I find a Soap Box comes in handy when getting on and off my High Horse!

Offline Jeff2uuuh

  • Newbie
  • *
  • Posts: 10
Re: 2005 R6 Idles like crap when it warms up
« Reply #3 on: April 06, 2013, 06:56:33 am »
The bike has a Yoshi slip on and Power Commander. Im gonna ohm out the coils today and see if I can find anything. 

The temp of the bike is 190-200+ deg. before it starts acting up.  You can listen to the engine idle down after it has warmed up. My problem starts after I ride and the bike is (hot).  Sorry I didnt explain it correctly in my first post.

Thanks for the responses so far!

Offline 8Ball

  • Mr. Clean
  • True Member
  • ****
  • Posts: 881
Re: 2005 R6 Idles like crap when it warms up
« Reply #4 on: April 06, 2013, 08:00:00 am »
How long has this been happening? How does the bike run off idle?
Quote from: jeff5150
just follow 129 on the map towards nc til it looks like a kid drawing it had a siezure
Quote from: Tomsljr
Know the difference between crack heads and Gap addicts? I have heard of people quitting crack.

I find a Soap Box comes in handy when getting on and off my High Horse!

Offline Jeff2uuuh

  • Newbie
  • *
  • Posts: 10
Re: 2005 R6 Idles like crap when it warms up
« Reply #5 on: April 06, 2013, 09:17:20 am »
I just got the bike so to be honest not sure how long this has been acting up. I also havent been around alot of r6's so i dont know how the engine sounds or the bike behaves. When I first start the bike it seems to run off idle just fine. When the bike reaches riding temps. it will not run on idle. It lopes pretty hard and then stalls. You have to give it throttle to restart. After I restart the bike it will idle fine until you bump the throttle or the fans kick on and it ads a drain to the system. I check the voltage coming of the regulator and its in spec. I just got done ohming out the coils and there in spec.

Offline 8Ball

  • Mr. Clean
  • True Member
  • ****
  • Posts: 881
Re: 2005 R6 Idles like crap when it warms up
« Reply #6 on: April 06, 2013, 11:14:00 am »
Where are you located?  I am in Maryville and have quite a bit of experience with the 2nd gen R6. Most likely the previous owner just installed a generic map that didn't have any changes to the idle range.  I have always said the generic maps may get you in the ball park, but Yankee Stadium is a pretty bi ball park.
« Last Edit: April 06, 2013, 11:14:31 am by 8Ball »
Quote from: jeff5150
just follow 129 on the map towards nc til it looks like a kid drawing it had a siezure
Quote from: Tomsljr
Know the difference between crack heads and Gap addicts? I have heard of people quitting crack.

I find a Soap Box comes in handy when getting on and off my High Horse!

Offline Jeff2uuuh

  • Newbie
  • *
  • Posts: 10
Re: 2005 R6 Idles like crap when it warms up
« Reply #7 on: April 06, 2013, 05:25:23 pm »
Im in Oak Ridge any help or input would definetly be appreciated. I missed last springs riding season and dont wanna miss out on this one.

Offline 8Ball

  • Mr. Clean
  • True Member
  • ****
  • Posts: 881
Re: 2005 R6 Idles like crap when it warms up
« Reply #8 on: April 06, 2013, 07:53:05 pm »
This may be a stupid question, but have you tried setting the idle speed once the bike is warmed up?
Quote from: jeff5150
just follow 129 on the map towards nc til it looks like a kid drawing it had a siezure
Quote from: Tomsljr
Know the difference between crack heads and Gap addicts? I have heard of people quitting crack.

I find a Soap Box comes in handy when getting on and off my High Horse!

Offline Jeff2uuuh

  • Newbie
  • *
  • Posts: 10
Re: 2005 R6 Idles like crap when it warms up
« Reply #9 on: April 06, 2013, 08:00:24 pm »
I tried tinkering with the idle speed but it only masks the problem. You can definetly tell its not running right even with the idle turned up.

Offline Curtie223

  • Moderator
  • Legendary Member
  • *****
  • Posts: 7556
Re: Re: 2005 R6 Idles like crap when it warms up
« Reply #10 on: April 06, 2013, 08:05:03 pm »
I would look at the power commander. It should run in a closed loop map until it reaches temp which is 190 for that bike. Then the power commander will take over with its programmed map. You can richen or lean across the board on the power commander by holding all three button for a few seconds with turning the key over. Personally I would try to richen or lean across the board just to see if that helps. If that changes it I would look at doing a different map.

Sent from my HTC One V using Tapatalk 2

 2001 KTM 300exc 
 2004 LTZ400



-When you see another rider keep in mind that is another friend you haven't had the chance to meet yet!!
-Riding is about doing what you love! No matter what you ride or how you ride. Just as long as you

Offline 8Ball

  • Mr. Clean
  • True Member
  • ****
  • Posts: 881
Re: 2005 R6 Idles like crap when it warms up
« Reply #11 on: April 06, 2013, 10:41:47 pm »
I sent you a PM.
Quote from: jeff5150
just follow 129 on the map towards nc til it looks like a kid drawing it had a siezure
Quote from: Tomsljr
Know the difference between crack heads and Gap addicts? I have heard of people quitting crack.

I find a Soap Box comes in handy when getting on and off my High Horse!

Offline Curtie223

  • Moderator
  • Legendary Member
  • *****
  • Posts: 7556
Re: Re: 2005 R6 Idles like crap when it warms up
« Reply #12 on: April 07, 2013, 08:42:56 am »
Any better?

Sent from my HTC One V using Tapatalk 2

 2001 KTM 300exc 
 2004 LTZ400



-When you see another rider keep in mind that is another friend you haven't had the chance to meet yet!!
-Riding is about doing what you love! No matter what you ride or how you ride. Just as long as you

Offline Jeff2uuuh

  • Newbie
  • *
  • Posts: 10
Re: 2005 R6 Idles like crap when it warms up
« Reply #13 on: April 07, 2013, 09:51:12 am »
I disconnected the power commander and the bike runs like it should. So is it a tuning issue or are power commanders prone to failure? Ive tried downloading differnt maps and the only difference I can see or hear is the amount of backfire on deceleration?

Offline 8Ball

  • Mr. Clean
  • True Member
  • ****
  • Posts: 881
Re: 2005 R6 Idles like crap when it warms up
« Reply #14 on: April 07, 2013, 01:24:20 pm »
Usually, the only faulty PC issues result in the bike dying very suddenly, or randomly.  Usually when closing the throttle at a high RPM, like entering a turn....scary. Ask me how I know. ::)

You may have a TPS sync issue with the PCIII.
There is a way to calibrate the TPS signal in the Power Commander.  I know you set the actual TPS, but the PC uses that signal, as well, and sometimes it needs to be synched when then are installed.  This procedure is not in the general install instructions, so it gets missed frequently.  The problem with doing it on the R6 is that you have to do it with the bike running, or by using the 9V battery adapter that you may not have been given with the bike.  Doing it with the bike running means that you will have the engine screaming at WOT for a second or two during the procedure.
Quote from: jeff5150
just follow 129 on the map towards nc til it looks like a kid drawing it had a siezure
Quote from: Tomsljr
Know the difference between crack heads and Gap addicts? I have heard of people quitting crack.

I find a Soap Box comes in handy when getting on and off my High Horse!